Troubleshooting the orange status light in WAMP Server

So you have installed WAMP and you cant wait to get going with your web development project, except there is one thing standing in your way, you have an orange status light when you run WAMP Server 🙁

In this post I will show you some of the things I have tried in order to troubleshoot the ORANGE status light in WAMP Server. I will try to cover as much as possible from the multitude of things that can cause WAMP to go Orange. Lets start.

  1. Check the WAMP Services.

    Head over to Control Panel –> System and Security –> Administrative Tools (Win 7 & 8) and open Services.

    Both wampapache64 and wampmysqld64 should be started. If one of them is stopped, it will cause an orange light.

    wampservices-set-automatic

  2. Check if port 80 is being used.

    If another service/application is using port 80, then you will need to disable that service as it will conflict with WAMP.

    To check what is using port 80, WAMP Server provides a handy tool within the Apache section of WAMP. Just click on the WAMP icon –> Apache –> Service –> Test Port 80

    troubleshooting-the-orange-light-wamp-server-port80-test

    If the port is being used by anything other than Apache/PHP then you will need to disable those services.

    troubleshooting-the-orange-light-wamp-server-port80-test-1

  3. Check your Host file

    Make sure that your hosts file has a localhost entry that resolves to your loop-back address (127.0.0.1). Open your hosts file by going to C:\Windows\System32\drivers\etc and either right-click on the file and select Open with  or double click on it to select your favorite text editor. Once opened, make sure that you have this line in there and that it is not commented out:

    127.0.0.1    localhost

    .. as shown below
    troubleshooting-the-orange-status-light-in-wamp-server-hosts

  4. Check these common culprits

    — If you find that IIS is using port 80 after you ran the Port check, you will need to disable IIS Admin Service and World Wide Web Publishing Service by going to Control Panel –> System and Security –> Administrative Tools (Win 7 & 8) and open Services.

    — If you have SQL Server and/or MS Visual Studio installed, then ‘Microsoft-HTTPAPI 2.0‘ may be using port 80. You will need to disable the “SQL Server Reporting Services” and “Web Deployment Agent Service“.

    — If you have another local server installed (XAMPP, DesktopServer, VAGRANT, etc..) you will need to disable that server in order to use WAMP.

    — I have read that Skype, Quicken, and WebDAV are known to cause problems with WAMP as these apps also use port 80. You will need to uninstall the application or make then use a different port.

Doing the above steps has helped me resolved this problem 99.99% of the time. I hope it can help you too.

If you have encounter this problem and found another way to resolved it please let me know.

If you have any feedback or have questions please let me know on the comments below and I will be happy to assist.

Thanks for stopping by.

4 Comments on “Troubleshooting the orange status light in WAMP Server

  1. Thank you very very very much Henry! you helped me a lot.
    just a quick trick to stop two services using command-line:
    first, start cmd.exe with as administrator and then write the following:

    C:\Users\user account>net stop was
    choose [Y] and then write:
    C:\Users\user account>net stop w3svc

    info:
    was [Windows Activation Service]
    w3svc [World Wide Web Publishing Service]

    Thank you again brother 🙂 best regards

Please Post Your Comments & Reviews

Your email address will not be published. Required fields are marked *

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.